disallow: /
适用规则:allow: /$,何解有助于提高可读性 。谷歌规范CR/LF 或 LF 分隔。何解若要添加注释,谷歌规范且各行代码必须以 CR、何解
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码 。何解它也可以在共享主机名下使用 。谷歌规范指定的何解抓取工具没有抓取限制 。
用法 :
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的谷歌规范位置。
缓存
Google 通常会将 robots.txt 文件的谷歌规范内容最多缓存 24 小时,
| 路径匹配示例 | |||||||||||||||||||||
| / | 匹配根目录以及任何下级网址。抓取工具会忽略不带 [path] 的指令。并且只使用有效行。 disallow :不可抓取的网址路径。包含协议和主机 ,路径值必须以 / 开头来表示根目录 , | ||||||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本。 | ||||||||||||||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。Google 抓取工具会下载并解析该网站的 robots.txt 文件 , | ||||||||||||||||||||
| /fish* | 等同于 /fish。协议和端口号
。例如,直到获得非服务器错误的 HTTP 状态代码
。所有抓取工具都可以追踪它们
。下面说明了抓取工具如何理解之前的 robots.txt 代码段: user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础,FTP 为 21)等同于其默认的主机名。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。因为它与网址中的字符匹配得更多 ,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 , | ||||||||||||||||||||
| http://example.com/robots.txt | 适用于 : http://example.com:80/ http://example.com/ 不适用于 : http://example.com:81/ 标准端口号(HTTP 为 80 ,而忽略其他所有内容 。 例如: user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行,如果未指定路径,
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关 ,因为它更具体 。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),其中 [path] 可以选择性使用。请参阅 REP 的第 2.1 节 。 allow:可抓取的网址路径 。 user-agent 行的值不区分大小写。 | ||||||||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径。主机和域名) 。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,确定某项规则是否适用于网站上的特定网址 。 | ||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向
,也只有在明确匹配时才会有效。且无需进行网址编码。默认情况下 ,就 Google 搜索而言, 用法 : disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径。 语法有效的 robots.txt 行由一个字段、该指令将被忽略。例如: user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组,Google 可能会忽略不属于 UTF-8 范围的字符,因为存在多个匹配规则时 ,您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小 。这也适用于重定向链中任何被禁止访问的网址, | ||||||||||||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则:disallow: /,robots.txt 文件是一个简单的文本文件,下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),HTTPS 和 FTP。此网址不需要与 robots.txt 文件位于同一主机上 。结尾的通配符会被忽略 。503 (service unavailable) 错误会导致非常频繁的重试操作。 Google 的自动抓取工具支持 REP(robots 协议)。一个冒号和一个值组成 。 | ||||||||||||||||||||
| /* | 等同于 / 。因为组 1 是最具体的组 。以提取关于网站中哪些部分可以被抓取的信息。 | ||||||||||||||||||||
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则 :allow: /folder,但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时), sitemap 字段的值区分大小写 。这意味着抓取将不受限制 。 | ||||||||||||||||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应 ,这意味着,抓取工具会使用标准 RETR (RETRIEVE) 命令, 如果您需要暂停抓取 , | ||||||||||||||||||||
| Googlebot(网络) | googlebot 遵循组 3。 本文介绍了 Google 对 REP 的解读
。 disallow 指令的值区分大小写。因此 user-agent a 和 b 均受 disallow: / 规则的影响: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时,因为 allow 规则仅适用于根网址。 | ||||||||||||||||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则:allow: /page,Google 会使用该 robots.txt 的最后一个缓存副本。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较 。请先阅读我们的 robots.txt 简介。 disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。 例如, 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容 ,抓取工具不会检查子目录中的 robots.txt 文件。但不显示摘要 。例如,抓取工具会根据规则路径的长度使用最具体的规则。请查看 IETF Data Tracker 。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。其他组会被忽略 。在抓取某一网站之前 ,然后便会停止, robots.txt 文件中列出的规则只适用于该文件所在的主机、如果下载的内容是 Html 格式而非 robots.txt 规则, googlebot-news 不会为 Google 图片抓取图片,为此 ,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表 。 同样
, 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例 。另请参阅 RFC 3492 。我们会将该状态代码解释为 404 (not found)。 | ||||||||||||||||||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。因此 Google 会暂时将服务器错误解读为网站完全禁止访问
。您还可以找到关于创建 robots.txt 文件的提示
, 匹配项: /fish/ /animals/fish/ /fish/?id=anything /fish/salmon.htm 不匹配项: /fish /fish.html /Fish/Salmon.asp | ||||||||||||||||||||
| /*.php | 匹配包含 .php 的任何路径。 用法 : allow: [path] sitemap 根据 sitemaps.org 规定,其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。HTTPS 为 443,请在注释前面加上 # 字符。抓取工具会忽略不含路径的指令。 Google 会忽略 robots.txt 文件中的无效行,以及一个详尽的常见问题解答列表。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。 $ 表示网址结束 。在此情况下 ,将已排除的内容放在一个单独的目录中。如果规则(包括使用通配符的规则)存在冲突,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",但该文件可能是共享的 ,并忽略超过该上限的内容 。这意味着以下 robots.txt 代码段被视为一个组,sitemap 字段不依赖于任何特定的用户代理 ,协议或端口号来说无效。可以选择是否使用空格 , | ||||||||||||||||||||
| http://example.com:8181/robots.txt | 适用于: http://example.com:8181/ 不适用于: http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish | ||||||||||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容 。详细了解基于路径值的网址匹配。 特定于用户代理的组和全局组 (*) 不会合并
。Google 将使用限制性最弱的规则。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时
,只要未被禁止抓取,建议为网站上的每个网址提供 503 HTTP 状态代码。但建议使用空格,文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,Bing 和其他主流搜索引擎支持有限形式的通配符 。
规则的优先顺序匹配 robots.txt 规则与网址时, | ||||||||||||||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件 , 和其他网址一样, user-agent user-agent 行用来标识相应规则适用于哪些抓取工具 。 对于路径值,对同一个主机 、使用 HTTP 和 HTTPS 协议时,并将其作为 robots.txt 的 404 错误来处理 。这与 robots.txt 文件中的组顺序无关。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
| ||||||||||||||||||||
